Lost Ark not starting up

Game anti cheat is starting up but Lost Ark game itself isn’t loading. Tried Verifying files, updated drivers (AMD Adrenaline) and it still won’t start update. How do I fix this? Game was working fine 3-5 hours before.

Hello @Tempyyyyy, welcome to our forum!

Thank you for reaching out about this issue and for sharing your troubleshooting steps, let’s try repairing EAC, follow the steps listed here:

If the issue still persist after you start your computer then please contact us using this link:

Let me know if this helps and remember you can share this post with our support department!


same problem
tried to fix the eac even tho i don’t think that’s the problem
it looks like the eac works fine and the lost ark client runs in the background but the game just wont open

hey go ahead and follow the path directory to that particular
“Untrusted system file … physxupdateloader64.dl” file, and delete it.

C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common

Run LOST ARK again and see if that helps.


Great reply, thank you. That fixed it for me.

I don’t know why, but it work form me to. Thx a lot !!

any fix solution if I dont have this directory? =(

C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common

it might be in a different directory, usually if its not working (splash art doesnt appear) its related to this error with NVIDIA. If your splash art appears, but doesnt open the game, you might have a different error.

Its the same error because I can’t see the splashart.
But I have AMD graphic not nvidia, thats why I don’t have that folder :sweat_smile:

Mmm sorry I’m not too sure then, my friend who I helped also used an AMD GPU with no previous NVIDIA GPU installed and he had that file path regardless. You can try checking other file drives in case it’s located on a different drive, but by default it should be in that file directory if I’m not mistaken. If anything, try sending a ticket to AGS