Lost Ark won't launch, nothing happen after EAC Overlay disappear

After today Patch I’m unable to launch lost ark, when I launch it from Steam, the usual EAC Overlay appear and load and then disappear as it should be, but the Lost Ark Overlay never appear (Both Lostark.exe and Eac are present in the Task Manager) but nothing happen…
I literally tried everything but nothing worked.

Windows 11 is up to date.
Clean Re-Installed Nvidia Driver (Up to date).
Repaired EasyAntiCheat (Both tried to uninstall and install it again and Repair).
Checked lost ark Files through Steam.
EAC/Steam/Lost Ark are running as Administrator trough properties of the .exe file.
Tried forcing -Fullscreen and dx9.
Disabled Steam Overlay.
Disabled any Background App (I only had MSI Afterburner since my Windows is completely debloated).
Added/checked permissions in Windows Firewall (lost ark, eac and steam).
Tried to disable Firewall and Windows Anti-Virus.
Tried deleting physxupdateloader64.dll (Even if I didn’t get any error about that file, But I read that It could help).
I even uninstalled Steam and completely re-downloaded Lost Ark from zero.

But nothing worked, I didn’t change anything in my PC, since this is literally a Lost Ark Machine, I always been able to play since release until today.

If anyone had something similar happened and could help it would be appreciated, since I doubt I will ever do a clean install of Windows just for Lost Ark.

I had the same thing happen to me.

I had to restart my system then when I tried to launch, I got a UAC prompt which I accepted, it did something and it worked for me after that.

I assume that EAC had to update something.

Sorry to hear you’re having this issue, Harvest.

I’ve moved this over to the support section so our support team can take a look into this.

Hi @Harvest.

Hope you’re doing great!

I’m sorry to hear that just after the most recent update, Lost Ark launch and then stop working on your PC.

This issue may be in relation with the EAC problem many other players are dealing with. First, thanks for annotating all the troubleshooting you have tried, and I invite you to check the troubleshooting list provided by the Amazon Games support page regarding this issue.

Then please take a look to the Roxx’s Mega Thread about this.

Once you have completed all the steps, and if the situation persists, we will need you to follow the instructions at the end of the Mega Thread to further assist you. I do apologize for all the inconveniences.

Wish you have a nice week.