Lost ark wont load


as per the title lost ark wont load, the EAC banner pops up, finishes loading and then nothing. No lost ark logo across the screen, nada. I have tried reinstalling, and repairing the EAC files. tried restarting the pc. The issue started after another DC occured yesterday, and normally I could force stop the app and just restart lost ark, but not despite all these attempts to fix the issue I cant seem to get lost ark to load.

any help or suggestiongs would be appreciated

1 Like


I see you have tried to repair EAC, could you also attempt to uninstall EAC. If that fails the steps below may help.

Hey, uninstalled eac and reverified and tried that fix already. Both arent working

A full reinstall may be a bit extreme, but what I’ll do is move this post over to the game support section of the forums, our support staff will be able to give some troubleshooting for you.

Greetings @BeyondYou

Hope you’re doing great , we apologize you still have issues with EAC , please refer to the troubleshooting steps on the link below:

After that if the issue persist please contact us to report this via a web ticket to our team :slight_smile:

Please visit this link to create the web ticket for our team:
Select In-game Issues → Something Else → Contact Us → Web ticket.
Amazon Games

Contact Us | Amazon Games

Thank you for reaching us !


Hey Eulah,

as state previously thats not working. A fresh reinstall of the whole game worked for about 20 minutes to the next DC, and then the problem persisted and cant play.

I have also been unable to launch the game after attempting the EAC fix.
Tried the fixes mentioned by Eulah and Ominous with no results. I have also done a complete reinstall with nothing changing.