Lost connection in abyssal dungeon and didnt get the pass

I’ve lost connection with my deathblade Kalinyx - Gienah - in the beggining of the abyssal dugneon. After like 1 min

Had to look on the forum to recover connection to the whole South America region. After I’ve solved all of this, I tried to re-enter the abyssal dungeon and didnt get any reward or the pass to do Aira’s Oculus.

Would like a solution, please

Hello @hmilagre.

Thank you for taking the time to reach out to us, I’m so sorry to hear that you got disconnected while playing the abyssal dungeon.

I understand how frustrating it is to lose the rewards from the raid due to a connection issue, so, your ticket should be replaced within 24 to 48hrs. If over 48hrs have passed without your ticket back you might not be eligible for the ticket replacement.
We don’t have a way to grant you the access back to get the rewards manually, I apologize for the inconvenience.

Here’s more info:

Hope this helps. Let us know if there’s anything else we can help with.

I hope you have fun in Arkesia!


1 Like

I still havent got the replacement ticket. In other words, you’re saying your server bugs out with my IP and I’m the one screwed?

That’s a load of crap from a multibillion dollar company. You should have an In-game ticket service to give a faster approach in problem resolution. Instead of making people go to a post in the forum and the moderator giving absolutely no solution.

Just to have a response that is: “Oh, in 24-48h you should receive or you’re no eligible.”
What a non sense response or problem solving there. You should care more about the player experience - problem with your server and I’m the one fucked

Pretty sure even those who got locked out valtan when the server crashed last week or so still didnt get their re-entry ticket to this day, my advice is to just accept that the support wont do shit to solve this atm.