Low FPS on high end computer

Even with a high-end PC;

*RTX 3080
*R9 5950x
*32gb Ram
*M.2 Storage
**Windows 11

I can not get above 20fps. I’ve lowered graphic settings. Tinkered with multiple OS settings (Game Mode, Xbox Game Bar, Power Management, Hardware Acceleration, etc) Nothing seems to help with my frames. When the game is running, my CPU and GPU usage is no higher than 30%. Is this game just poorly optimized for higher-end CPUs? Any help is appricated.

1 Like

Is there a way to view FPS in game?

High End stuff usually have some frame problems with older or weaker games/softwares. Idk why but it does. I may know how to fix it. Try to limit the usage of your CPU for Lost Ark. Open the game and then alt tab do desktop, then, you need to open up the task manager. When you did that, go to “Details” option and find Lost Ark there. Right click on it and go “set priority”, set the priority to the lower one, so your CPU doesn’t put that much power into that game. Again, I don’t know how this particulary works, but it works, most of the time.

Its giving me an access denied error. Im also on Windows 11, forgot to add it to post

Same i don’t have a “high-end” computer by any means but it should have no issue running this game. Dungeon was TANKING to 20 fps for me the entire time

  • ryzen 5 2600
  • 1660 ti
  • 32 gb RAM

4k&5k resolution 150-200fps with 3080 ti, i7-12700k, 32gb ram, m.2,
and game just crashing in random moments, no error messages, thats sick…

So it seems you are not having the same issue as me. Your CPU/GPU is on par with the people I’ve chatted with in the LostArk discord. But most of them are hard stuck at 20fps. Are you running RU client? Did you do anything other than downloading and running the game?

Asus GPU TweakII application and ‘gaming booster mode’ it’s turning off all shit apps => boost fps

Even with my “shit apps” turned off hard stuck at 20. Seems we have a different issue.

Finally fixed my issue. This is a temporary fix as games should not be given permanent admin privileges.

MY SOLUTION: go to steam page, click settings (cog wheel), go to local files, browse… , go to binaries, win64, scroll down to the executable (“LOSTARK”), right click and go to properties, then compatibility, and check the “Run this program as admin” box, restart computer

2 Likes

Had the same issue on my RTX 3090. Had stuttering 60-70 fps. After doing this iam back to rocksolid 120 fps. Thank you alot.

Did not work for me :frowning:

None of the solutions I read here worked but then I read somewhere about Cleaning registry with Avast Cleaner (who also has an antivirus app and is safe) and it worked! You don’t need to buy just use the Scan for Free option and then fix everything it recommends. It doens’t tell you to restart your computer afterwards but that’s when it was finally better and running buttery smooth now (don’t forget to turn off area chat too (as mentioned many times earlier)).

Something else worth trying. Switch from DX11 back to DX9 i have issues for some reason on D11 but this helped me, maybe it does others.

Try to use that, since i blockd chat = no fps drops / low fps

Maybe a bit late but have you guys with the low fps on good hardware checked the windows feature called fault tolerant heap?

I would advice against disabling it completely but if you are affected by fth misbehaving or making software misbehave you can safely delete the fth list entry for lost ark (if there is one) or any other game / software that suddenly runs slow or unstable.

We encountered the same problem with fps not being able to go past 20 when playing Blade and Soul numerous times and we were able to solve it by removing the blade and soul entry from the fth list making it playable again with the usual fps rollercoaster that BnS was.

Here is a link that describes it pretty well:
https://coronarenderer.freshdesk.com/support/solutions/articles/5000678431-windows-enabled-fault-tolerant-heap-for-3dsmax-or-dependent-processes-this-may-have-severe-perform

This was the only thing that worked for me. Was getting about 50 fps on a RTX 3080, and after forcing admin mode - my fps is now above 200 @ 1440p.

this worked forme… thanks

This guy’s video helped me a bit in tandem with the granting administrator thing. Overall, moments with a lot of stuff happening I’ll dip from 140 fps to 60fps. Still looking for a complete solution.