Metus island - werner's manor

Yo,

I just tried to do werner’s manor but i seem to be stuck at the start, im suppose to find a key to open the door but i cant find it, i saw multiple youtube guides where it should be but its just not there for me


It should be in this bookcase . What am i doing wrong ? is this a bug ?
I also noticed i’m in Werner’s manor while the youtube guides are in werner’s grand manor, whats up with that ?

I searched both the rooms and corridor multiple times, i cant go back futher.
Restarted the dungeon multiple times, same issue, even abandoned the quest and tried again, nothing…

1 Like

Hi there,
guess you doing it right.
I have the same problem… indeed looks like a bug

just checked, still bugged, maintenance did not fix this

have same problem , every yt videos showing there but cant find in that room anything

bump on this, is bugged, can’t get key

1 Like

Ye bugged, FIX IT AMAZON!!!

Still bugged… very frustrating it’s been DAYS!!! Should be fixed by now…

all have same problem…it’s bugged

well lets hope its fixed with the patch tommorow, so we can do the worst quest in the game for the soul

1 Like

“Fixed an issue where the “Look for the key to the door in the hallway” step during the Silent Manor Quest on Metus island was unable to be completed. You can now progress through this quest as intended.” todays maintenance

can confirm it is fixed and that it is the worst quest i have ever seen in an mmo