Missing a skill, Overdrive from berserker

Hello !
I recently checked out my berserker and I noticed that the skill Overdrive that is supposed
to be a replacement for Strike wave is not there. No matter how hard I look and everywhere I look, I do not have the skill at all, anywhere.

I later chatted with support, they also confirmed that they couldnt find it on my berserker. So now my question is, anyone else having the same issue? If you do, were you able to solve it? if so, how?

I am sorry but I was looking forward to this rework for berserkers and I am literally or probably the 1-2 guys that cannot experience it. I am frustrated, irritated, please bear with me. I am desperately trying to find a solution. The support from amazon said they cant give me an answer the next 48-78 hours because they just filed the issue to whoever in charge of this area.

Ok I got the answer from support team, they said I have the overdrive skillbook in my storage and can be learned… I had so many skillbooks saved up in my storage, never thought it would look like a engraving book.


well its the last skill before awakening, dumb question have you done both of your awakening quest or if its a new character go trixion and talk to winged lady and see if its there for you

1 Like

Yes I have both awakening skills and have done both quests. It is my first character created on launch and also played since launch. He is also in my top 6 gold farmer.

and the skill is just gone? thats insane, sorry you going through that. I would honestly (and I know it sucks) reinstall the game. Maybe go ask in the discord and see if anyone else is having the issue. I feel their has to be a simple solution. And if is a bug why is only affecting you and not others.

Yeah i am very sad it only affects me i think, i asked around for a few hours on discord and only 1 guy responded he had the same issue. I will try to reinstall game tomorrow hopefully it helps. Because amazon will probably not do a quick fix soon for just one guy sadly

Good evening everyone.

I’m having the same problem, I’m checking the local files on steam to see if it’s a corrupted file

Heyo ! Lookin forward to good news…

I’ checked the integrity of the local files and it still doesn’t show up =[

It seems to me that the skill was not obtained.

So it’s not a visual bug in skill selection.

Maybe when you level up it appears, but after lvl 50 it’s hard to level up hehe


First at all. I don’t have this problem so I can just guess:

Have you tried rechecking inside Trixion if she got a quest same like in the second awakening questchain where you get your second ult + skills? Not that there is something bugged there.
I know this is a dumb question on my side, but am just trying to help (:

1 Like

This screenshot pretty much answers your question I think and yes I have both awakenings, got the quests done

And the overdrive skill should be at the bottom together with the two awakening skills but thats not the case. Skillbar also shown on the second screenshot

I can also add that, I did not have Aura blade before the patch. Aura blade are supposed to be replaced by Brave slash (which I have). If I am correct, Aura blade is the level 50 skill that is coming with the second awakening skill. On the other side, Strike wave are supposed to be replaced with a skill called Overdrive, but strike wave is not a level 50 skill. Technically I should have Overdrive but not brave slash since I never had Aura blade.

Update on the missing skill, this screenshot below shows that my berserker have not learned skill yet therefore I cannot use the “Recommended”-import system. Yes I tried to import Overdrive setup from the Recommended, but did not work, it only shows the system message saying that I do not have the skill learned

1 Like

I tried to import the skill, just like your example and got the same result:
“do not have the skill learned”

Remove the „sort by equipped skills“ -the skill has a different name than overdrive. I think it’s called overcharge or something. Will check when I come back from work later this day

Sorry that it wasn’t helpful at all, but I am now out of ideas. Cause this have been the case for me when I missed a skill that I forgot to use after picking up cause it looked like an item and threw it into my normal storage.
So checking universal storage wouldn’t be an option either.
Welp, sorry to hear but I guess I can’t throw in additional ideas, good luck solving it and please inform us once it solves so can maybe help anoter poor soul in the future

1 Like

We take anything and appreciate any ideas thank you. Keep throwin more ideas if possible, maybe we can solve it before amazon comeback with a solution/answer. Which takes more than two workin days… up to 72h.

1 Like

Try to log off. Go to directly to steam and check if theres an update, otherwise verify game files.

This has happened in the past where you could force your way in game before steam updated lost ark and tons of things were messed up.

Good luck.

no luck sadly :upside_down_face:

I also have the problem with the missing skill (overide)
And still the support is working on it. For 3 day, without any good results for me.

I just finished the Norht Vern story with berserker and Story Express, went to Tixion and claimed both awakenings but i don’t have the new skill of the berserker.
Don’t know if its an error or i will obtain it later.
For now i will do Sushire story and see if they give it to me after that.

Problem solved.
The Book looks like a Epic one…
See here…Thankz a lot.

1 Like