My game won't load

I pre-downloaded yesterday and I was able to unpack the game today, but when I try to start it I get the anti-cheat window which then disappears to be replaced by a graphic with the Lost Ark logo… and then it stops and the blue STOP button in Steam resets to the green Play button.

Hi @d.laberge :dragon:Thanks for contacting us

I’m so sorry that you have not been able to play Lost Ark, we don’t want anything to mess with your Lost Ark experience.

We can try to verify your files in steam to solve the issue:

  • Restart your computer and launch steam
  • Right click the game in your Library, or click the gear icon from the game’s Library page on the far right.
  • Select properties
  • Local files
  • Steam will verify the game’s files.

Let me know if this works.

Thanks for your patience! :dragon:

Checking the file integrity did the trick! Thanks for the help!!

I’m having the same problem but i have done everything and nothing worked. please help.

Hello, @bjbonanno

Hope you are doing well.

I am really sorry to know about the issue you are experiencing.

As you have already tried the above mentioned troubleshooting steps. I would request you to please contact us through live mediums so that we can further escalate this by creating a ticket to the Dev team for a resolution.

You can contact us through live mediums by following the below link

Amazon Games

Contact Us | Amazon Games

Support for Amazon Games. Read support articles or get game & account help from Amazon Games support reps.

I hope this information helps.


Ticket was submitted (4 days ago) I’m hoping they will find something soon.