New Bug: Items getting stuck on cursor

Had this today so… bumping

Same. Happened to me twice after doing Levanos and going to the Storage NPC. I had to go to my Stronghold for it to be fixed. Super annoying.

same. still happened today

1 Like

This happened to me as well. I just switched to another character, and back again…

Also frequently happening to me on different characters since last maintenance.

Happened to me first time last night after downing Valtan.

bug just occurred for me after guardian raid

Sticky Till fixed please

@roxx ?

I got the exact same bug. Still not fixed.

it also happened to me twice this week

got this bug 3 times today alone, def needs a fix.

Same here, had it 3 times and twice it fully crashed my game

It has happened to me at least 6 times.

the bug happened to me so many times today, however the worst one that happened was when my INVENTORY screen locked onto my cursor. Even when i pressed “I” to close and reopen it, it would still be stuck. I couldnt left click on anything, including to switch characters when i pressed esc or to confirm that i wanted to use a bifrost/song of return. moving to another area didnt fix it either. had to alt + f4…

Same issue with inventory item, also happened to me with a song, quite inconvenient knowing I was trying to complete a coop event lol.

Also experienced some bugs with the chat window tonight, simply tried to make it bigger since I was going to sit in Nia ch1 for a moment and the ‘sizing’ tool got stuck on the size I wanted but my actual chat window stayed the same size as it was. Had to go back to character screen, triport didn’t work ))

Happens at least twice a day for me. Would like fix +Aura and Leapstones for time lost

bump - i understand its the weekend and over night, but want to bring more visibility to this ongoing issue.

I has caused issues in dungeons and raids as it makes it so you can’t place things on your bars, thus griefing by not having appropriate loadouts.

Many thanks for bringing this to devs attention.

9 days and not a peep from the team. Thats some crazy shit right there…Ya’ll need to increase the size of the team asap

I had it once but got to accept a guardian raid with enter and after changing screens it got fixed
A guild mate didn’t have the same luck when it happened to him and had to restart mid valtan

1 Like