Newbie looking for basic guidance

I just started playing, nobody to help me, trying to figure this out for myself and I can’t even get out of Pridehome! So my problem is super simple and stupid—can’t believe I can’t figure this out. When I first entered the game (in front of the cathedral) I finally figured out how to walk/move and that I had to talk to that brother whatshisname to get a mount. I selected a mount, assigned it a quickslot, F1 (since changed to 5) and mounted it. My quest journal says I still need to mount a horse. I’ve tried talking to just about all NPCs in town to see if I could spark a quest, and nothing. Would you mind taking a moment to tell me what I’m missing. I’m resisting giving up on this game before I even get started!
Thank you in advance

if you still need to mount up, have you tried opening the mount tab, selecting the mount and clicking the “ride” button? but yh you have to follow the “main quest” you cant skip doing it.

If you want other guides and stuff check like maxroll or the community guides think the community ones are on this forum somewhere.

yes, I selected ride. As for the main quest, there are no quests in my journal. Just to mount and ride the horse.

Can you add some screenshots of your inventory, quest journal, and mount menu?

@lenayev try riding the mount from the mount window, one of the bottom right settings has a “Mounts” option that opens a window with all your unlocked mounts–try riding it from there?

The first screenshot is the Welcome challenge window, iirc this has nothing to do with the quests. Check your minimap in Prideholme if there is a questionmark where you can pick up the next main quest.

I think you only select the mount you will receive as reward from a later quest. You will have to finish that quest first before being able to ride it. No worries that doesn’t take long until you can use your mount. With alt + v you can open your mount window. You will not find many players in the first continents of the game, most people that create new chars already played through the story and can skip doing it a second time with powerpasses.

Thanks everyone. I’m slowly making progress. :wink: