Nineveh rapport quest "Aura of Chaos"

Foggy Ridge - Track the trace of chaos at the Sanctum of Mist

Cannot enter the Sanctum of Mist
The entrance doesn’t work. I’ve abandoned and re-accepted the quest, but it didn’t work.
Relaunching the game also didn’t work.


same problem here. any updates?

Can confirm, not working!

Yep, still not working.

Can confirm as well, it is not working . If i remember correctly the quest leads you into Mystic (raid boss ) instance but it has been removed in our version of the game.

It does not work for me as well :frowning:

Yea, quest is bugged and cannot be completed. Hopefuly will be fixed soon…

+1 same issue here

+1, encountering same issue

+1 same issue

Gonna go ahead and add myself to this list. Tried relogging and exiting the game, and nada. :frowning:

ayo fix this already…

Where is the Sanctum of Mists?

I’ll add myself to the list as well. Can confirm that the sanctum of mist is not working as intended.

Where is the Sanctum? :o

Bugged here as well.

Same here, nothing happens when i go to the questionmark at foggy ridge

Rip another bug. Can we have something working :(?

Same bug for me.

I can’t enter either.