Not able to complete Quest "Honest Liar" due to missing []

Hi everyone,

I am not able to give in the quest “Honest Liar” to NPC “Hacker Siltero”. The tooltip says “!! You need to have the item [] in your inventory or your roster storage to talk to Siltero the hacker.”, but i do not have the mentioned item anywhere in my inventory, storage, roster storage or pet inventory.

I am also not able to abandon the quest. So i am not able to complete the quest in any way.

1 Like

There are a couple threads about this issue, one of the guy said that he contacted the Support and that they replied that the issue was logged but that they cannot do anything right now.

His map disappeared when doing the quest and entering an arena match.

Yes it sucks, i hope this gets fixed in a future patch soon.

1 Like

Hello @Atje!

I’m sorry to hear that you’re having issues with the “Honest Liar” quest.

This seems to be an issue our Developer team is working on.

Now, I found this while checking for possible workarounds, maybe you can try it:

Now, if that doesn’t help your issue, and considering this is a bug, please contact us to our live chat to raise a ticket for your case: Contact Us | Amazon Games.

Thank you @Swars for taking the time to help a fellow player!

Thank you both for your time.


Same problem, i’ll test the possible solution.

It worked for me just as it is there, press G to talk to the guy, then at the bottom right there is a bar with the name of the mission do several clicks and at the same time press G several times as well. It is solved that way. Thanks for the info.

The “workaround” (pressing G and LMB mutiple times) worked for me.

I cant even talk to Siltero. Any fixes yet ?