Official Galatur Thread

Hello again,

Apologies for the delayed response and thanks for sharing this with me, I tried making some adjustments on our end but I similar to the other players I tried to help earlier, it is part of the issue that the team is still trying to fix.

Sadly, I’m unable to reset your lab research progress as I’m only limited to do certain tasks on my end, but I will raise this to the team. This is really informative and would help them to check on the issue preventing the players to progress on quests.

Thank you!

1 Like

Dang, that’s unfortunate. My stronghold has been bugged since the 11th, I had a glimmer of hope when I saw you reply but if there’s nothing you can do currently I guess it’s back to waiting lol, this sucks.

Edit: Thanks for helping the others at least, it was more of a bummer to see this thread go quiet for so long, even if there’s nothing new to add an update of any sort is better than nothing.

Thanks for trying. I can see the A Necessary Procedure quest now, but I still cannot complete it since the research task had already been done. I hope a fix will come soon. I’m not sure if it is possible, but if that A Necessary Procedure quest could be set to complete, I may be able to proceed further with no more issues that I know of yet.


I completely understand how you’re feeling.

Currently, I have limitations on what I can and not do for the players. Right now, I’m able to check on quests missing and try to help as much as I can.

I wish I can do more for your issue but I’ll raise your feedback to the team, so we can improve on how we handle player’s issue moving forward.

Thank you for understanding.


Online Now
Character Name: Sed
Last Completed Quest: Weight Of The Wounds
Please help :slightly_smiling_face:

1 Like

Hi Chesca, I am currently online now.
Character name: Nicelogicbro
Issue: The quest “Issue for approval!” in the stronghold.
Server went down after I completed it, now its asking me to re-research something thats already researched and I cannot


Thanks for getting back to me, I tried but it appears that I cannot manually complete this one on my end.

I think it’s now better to wait on the official fix than to troubleshoot your account more as I’m only capable of checking certain things.

I’ll raise this for further testing before doing it to your account.

Thank you!


Thank you for the help. I will keep an eye out for any news on the fix. Though, I will need to log off for now. I will most likely be back on tomorrow around 6pm EST.

Nevermind, I just saw your response to someone with the same quest as me :(, hope it gets fixed soon

Thank You Chesca :grin:

In game Name Jobeef
server Galatur
Quest needing restoration : the watcher (where you receive the 3 or 4th ark)
Last quest complete- those left behind

I was able to complete main story but I’m still missing this quest completion and cannot get my second awaking skill without having this quest complete.

1 Like

Of course, I’m here for days and days, no CS response…but I take one day off and they show up :frowning: fml I guess


Are people really getting their quest fixed?

Last blue world quest on Tortoyk: Keep Farm From Harm

I need blue world quests restored on Tortoyk so I can complete that area for the ark and song Hearts Melody. Please help. Like everybody else here, I’ve been pleading for days. I will provide screenshots when the server is up.

@Chesca the last completed quest I have on Tortoyk is “Keep Farm From Harm” and the next one I need to progress again is “Some Assembly Required.”
I am currently Online as of servers coming back up and will be online for the foreseeable future. Please help me.

@Seawolf @CyFy @Shadow_Fox @Roxx @Chesca @ArthurFleck

Online Now

Server: Galatur
Name: Gosuu
Missing Main Quest: The Frozen Sea

I cannot do Shushire or the second awakening quest until this is restored :frowning:

@Chesca I would like to add that when I lost the blue world quest in question during the three day head start I left the continent that I was on and proceeded to get to higher levels. The latest world quests I have completed were in Feiton. I have quite a few quests locked behind the things I am missing from Tortoyk.
For clarification the MSQ blue world quests I need restored are on Tortoyk, as shown in my screenshot. My last completed quest is “Keep Farm From Harm” and I need the following quest “Some Assembly Required” restored to my character.

Character: Joeyhighbody
Server: Galatur
Status: Online

Thank you for confirming that the issue can’t be fixed by support. I really appreciate the transparency, wish it had come a bit sooner, but it is greatly appreciated none the less.

Since all we can do now is wait for a developer fix Can you guys at least add the stronghold issue back to the top issues thread in this forum so we can check the status there instead of having to message support to get an update?


Hello @joeyhighbody

I have successfully added the most recent world quest in order to unstuck you on progressing further. If the issue persists, please let me know.

Thanks in advance.

1 Like

Hello @Gosukusan

In order to avoid any mishandling on my end could you provide a screenshot from “Completed tab > last World Quest completed”, please.

Thanks in advance.

1 Like