Please update EAC to latest version

It’s well know that other games running Easy Anti-Cheat will NOT run because Lost Ark uses an older version of EAC. I bought a founders pack to help out this game. I also play another game (that i’ve been playing for a year and a half and am heavily invested in now) that uses EAC and it will not run with LA. Don’t make me choose because you won’t get any of my $$$ until it’s fixed.

1 Like