Problem with buying royal cristals

Does anyone suffering from crystal shop as well???

All packages that i try to buy is giving me the same message.
Not even open anything to type my credit card or paypal

Hello, @Whatica

Thank you for letting us know about this issue with the crystal shop, could you try restarting your client? and let me know if the issue persists please.


pastedImage (3)

Hey there @Muzz I have the same problem. I can confirm that if you select a lower tier ($49.99) the steam overlay will pop. However if you do buy the lower tier you can’t seem to buy a second version of it. You will get the same error message. You have to then buy the next lowest tier at $19.99 and then the same problem repeats.

Restarting client & verifying files does not seem to solve the issue

I have the same issue as well when attempting to purchase royal crystals, attempted restart of client as well with no success.

can confirm the same problem as of today same as mash,
buy the $100, and if you try again it will say purchase fail, the same goes for all the lower royal crystals lower tier, game is treating them as of today a 1 time purchase, and you will get purchase failed after.

none of the restart client nor run as administrator fixes this, its the game side problem
can we get a fix on this please?

Same issue, verifying files, restarting, running as administrator. Nothing has helped.

hi @Mash thank you for replying , I’m currently investigating your case folks. @Dreamos , @iampaul85 (Welcome)

for the mean time , could you double-check for me on your steam account the following?

  • Open Steam.
  • Click on your name, and select Account details.
  • Select View purchase history.
  • Look for your Royal crystal order.

pastedImage (3)

Notice that I could only buy the next lowest, and now cannot buy any.

Mine shows no purchases beyond the earlier 100.00 similar to what the other posters are seeing on their end.

previous purchases are all there up till today, none of the “failed to purchase” is recorded in steam purchase history

Same, no failed to purchase recorded in my history either.

I just doubled check and im facing the same problm here as well . I was able to buy cheapeast packages one time and now i cant buy any

Also can’t buy any royal crystals

I can buy every pack except the $100 one it seems but I’m only wanting to buy the $100 one. This has been going on for days that the $100 one fails.

I’m back folks , I’m afraid to tell you we have an ongoing issue with the store right now, our dev team is aware of this problem, I just found it out , I’m sorry mates.

pastedImage (3)


Don’t you all have phones!?

Sorry I’m not sure how else to respond… I’m glad it’s being worked on =P I hope I can hand over my money to you all soon.

Hello Muzz, I’ve been tracking this thread for a while. Thank you for your assistance as usual. Has the issue been rectified?

Edit: It has

It is back again. I was able to buy a pack that I couldn’t yesterday, then again today I am getting the error. Purchase Failed again. It seems after this last fix that it only fixed it for one purchase, and the problem repeats again.

yup was fixed for 1 purchase and problem is back again. do they have a daily limit set or something?