Punika Powerpas consumed but didn't work

I am Statix on the Galatur Server and I tried to use my Punika powerpass. The pass dissapeared and I logged out to get to the character select screen but the pass was consumed and I was unable to use the pass.

I would like someone from Customer Support to assist me.

I also tried logging completely out and back in, and verified all local files. There is no Punika powerpass option for me to use.

Thanks,

1 Like

Hey there – Powerpasses are currently disabled from use. Once things are back up and running this should get resolved.

3 Likes

I also have this same issue. I “Used” the Punika Powerpass Token and was then unable to apply it to a character. The only announcement AGS made was that PURCHASED Powerpass was disabled, thank you for informing us that ALL Powerpasses were being disabled! I am expecting my EARNED Powerpass to be reissued, or at least be able to apply it to the character of my choice, SOON!

Same issue here for the Punika powerpass.

Are you referring to the in-game messaging? Thanks for letting me know, let me see if I can get this fixed!!


I received the powerpass through the mail, claimed it into my inventory, right clicked it to be used, went to the character select menu, selected the character I wanted to use the powerpass on that was eligible, and that is the screen I get. It doesn’t show my Punika Powerpass.

2 Likes

Ah. i didnt see this. Thank you roxx.

So how does this work now? Will the pass be reimbursed? Only reason I ask is, if this is going to take a while. I will probably level the character through Punika if this takes more than a day to resolve. I was seeing the same thing as Fyrehawk and jmpinoy…

When is this going to be back up? I’ve got a sorc waiting to boost to punika with 2200 royal crystals ready

Or what? What are u gonna do about it? Kids These days.

1 Like

Wow.

I’d like to know too, 2 days and a core function in the game is unavailable. PAIN.

I also have the same problem (with Vern pass too). It says I have available but when I log and pick a character it returns a complete black image with a count of 0 pass.

I’m from South-America server Prideholme.

First Image:
image

Second Image:

1 Like

Same here, i tried couple hours to sort it out, made Amazon support ticket with these same infos and this was they’re reply.

"I’m sorry for the trouble with the Punkia Powerpass, if the characters won’t show up at all, let’s try this troubleshooting steps first:

  1. Run a Steam Integrity Check for Lost Ark.

Some players were successful resolving minor bugs and crashes by toggling IPv6:

  1. From the Start/Windows Menu, select Settings.
  2. Select Network and Internet.
  3. In the Status section, under Change your network settings, select Change adapter options.
  4. When the Network Connections window opens, right-click your network connection.
  5. Select Properties.6. Scroll to Internet Protocol version 6.
  6. Uncheck the Internet Protocol Version 6 (TCP/IPv6) box.
  7. Select OK to save your changes for the selected network adapter.
  8. Try launching the game again. A PC restart may be necessary.​

If the issue persists, please contact us with the following information:

-Name of the character, server and region.
-Details of what happened such as date, time, place on map and else.
-Any other information you consider that may be of use such as screenshots attached.

Thanks for contacting Amazon Games​.​​"

They cant even spell Punika right, Amazon customer support is so useless.
next time going to come here first.

you are doing too much. Roxx said all the powerpasses are disabled. We are waiting for AGS to bring them back online. Check the dev tracker.

Like i said, check this forum always before contacting Amazon support (this is more usefull. I came here after all that.

The same thing here, there is no power pass for the demiozen, it shows that there is no image available

is it disabled someone knows

Have any of you managed to get your punika pass reimbursed ? I used mine not know of the bug and its simply gone. I have reached out to support but they simply don’t reply even.