Quest "Honest Liar" bugged? Can't progress

So im currently stuck on this quest Honest Liar - Lost Ark Codex my current objective is to apologize to Hacker Slitero in Stern, however I can’t progress. Even after emoting or speaking to him it just shows “…” and nothing else happens. The device i had in my inventory that started the quest is also gone.


I have the same problem.

I am also facing the same issue, cannot progress in the quest. unsure if its a bug or there is something else that needs to be done.

It’s not bugged. You need a certain treasure mao. Although the item description seems missing as it is:

I had the treasure map, but it was consumed on one of the previous parts.

same problem here - robot is broken and map is gone from inventory - cant go on with the quest

// edit: spamming “G” for 10 second unbugged the quest while talking to him !


@Kandera Thank you! that worked for me as well.

Confirmed same issue - map was taken out of inventory - cannot apologize to the hacker

Spam “G” and it will work.


Thank you! Spamming G worked for me to get passed the bugged quest Honest Liar - Apologize to Hacker Slitero in Stern Underground Market.

this worked

ty, this worked for me


this is awesome

lol, thanks, that worked! you must’ve been really angry and just started spamming “G”. who says anger is bad? :smiley:

I can’t believe that they put “…” over 10 times to emphasize how mad the stupid kid was. Thanks for letting us know that

Thanks a lot man!!! It works

apparently we have to hack him.

Thanks. It worked.

Thanks, this woked for me as well <3

i cannot even click or press G on the NPC, the marker is missing on the map :frowning: maybe because i used another char to continue the quest? I passed the item over a new char and used it from there cause im planning to main this Knowledge transfered character

1 Like