Quest is missing after Galatur server maintenance

yeah thats what it sounds like… usually with things like this its a server wide issue and they have to do another maintenance to fix it. im sure that’s what will happen again.

That’s what im thinking too. It’s for sure an issue on their end, how could my PC files have anything to do with it.

if i have to start a new character that wont bother me to much. I only had the bronze pack. I dont even know what it came with haha. I just got it to be able to play early

yeah i got the Plat pack … rip

ouch

Amazon Your Account Amazon.com
Message From Customer Service
Hello!

Hope this email finds you well.

I am sorry to hear that you are currently having some trouble with your main quest after the Galatur server maintenance.
This is a known issue that has been already reported and our team is working on it to get it solved as soon as possible.
Please check the following forums articles to understand this situation in a deeper way:

Galatur Account Issues
What happened to Galatur, its gone? - #1205 by FinesseXIII

Please provide us with your DXDiag. This will allow us to look further and with more detail into your issue.
Instructions for finding the DxDiag on the following link: Open and run DxDiag.exe.

Also, please provide any screenshot or other kind of evidence you think that could help us to investigate further. If you do have some, then please share with us by attaching the information as files on the email reply.

Kindly let us know if you have any question, it would be a pleasure to further assist you.

Thank you for contacting Amazon Games. See you in Arkesia!|
|We’d appreciate your feedback. Please use the buttons below to vote about your experience today.|
|Best regards,
Leo B.|
|Amazon Game Studios||

log in / log out and validate files didnt work lol imagine that

Yeah it will definitely need to be resolved by another maintenance to fix the 100s if not thousands of people who are experiencing this same issue,

i wont be making a new char as i already put lots of hours into this character and was just catching up with my friends who started on launch.

Kind of upsetting, to sit around waiting for maintenance to end, just to not be able to progress anyways…

did you trying blowing on it?

this is irratating lol. So we have to prove to get our progress back

lol right good ole N64 days

lol

Greetings Adventurer!

This is Con, from Amazon Games Support
Thank you for reaching out to Amazon Games.

I understand how inconvenience it is to not able to continue the quests. As a gamer, I will also be worried about it.

In accordance to this issue we can try a simple trouble shooting steps like:

If the issue still persists, feel free to contact us again so we can create a ticket for you.

Thank you for playing Lost Ark. See you in Arkesia!
We’d appreciate your feedback. Please use the buttons below to vote about your experience today.
Best regards,
Con C.
Amazon Game Studios

they legit told me to uninstall and reinstall the game… ffs

1 Like

Same stuff happening to me and their customer support responses are laughable … like wtf is this? They can’t even give us any feedback on what’s going on or any ETA or even that it’s being worked on. We paid for early access and after a 5 hour downtime got hit with a ??? amount of time before we can actually progress our main characters … it might not even be resolved before Friday the official release date. This is a joke.

1 Like

They even posted to their twitter when the downtime first started saying:

Galatur (US East server) is currently down for maintenance.
We apologize for any inconvenience, and will update this thread when we’re back.

They never even posted when the server came back online. CS is lacking HEAVY.

lmao UNINSTALL AND REINSTALL the 70 Gigs??? some people are on data caps (not me , i feel bad for those people) but fuckkkkkk that ol

and im missing powerpass and founderpack
id : Khiris
server Galatur

Same here. Main quest is gone. Server: Galatur Character: Luxarr

Allow me to dog-pile here. I have no main quest that I can accept after the server went down. Based on my completed journal I can tell exactly where the next quest should be but there is nothing to accept from any NPC. This has been more of a 1.5 day head start rather than 3.

Server: Galatur (obviously)
Character: Socrex