Quest Item ''[Awakening] Ray of Hope'' bugged - didnt receive it

Hey guys,
I just recently got the ‘’[Awakening] Ray of Hope’’ Quest for my Sorceress (V) and I’ve come across an issue that’s been bothering me for quite some time now. The quest Item you usually receive in order to learn it, didn’t show up in my inventory or in my mails, which prevents me from learning my ultimate and progressing in the quest line.
Has anyone encountered the same issue yet? What can I do to fix this?
(I already thought about abandoning the quest and going up to the npc again but it’s not letting me)

Hello @Asthera,

Thank you for taking the time to reach out to us, I’m so so sorry to hear that you’re having issues with this quest.

Let’s do this:

  1. Close the game.
  2. Verify game files integrity. (Steam Support :: Verify Integrity of Game Files)
  3. Restart PC.
  4. Launch Game.
  5. Abandon quest.
  6. Talk to NPC.

If it is the case that you’re not able to abandon the quest as you mentioned or you don’t receive the item please contact our live support to get this issue escalated.

Hope this helps! :mage:

1 Like

Did you check your quest items tab, it is exactly left bottom icon in your main inventory.

Hello. The same thing happened to me yesterday.
I received the quest Ray of Hope for Gunslinger (Eye of Twilight), but don’t have anything in my inventory. I also checked mail, pet inventory, quest inventory, even personal storage and mail box and nothing there.

I verified today the files integrity and still no luck. I cannot abandon quest - Abandon button is disabled.

Has anyone else gotten this fixed. I searched all of my inventories and followed the steps above. Nuttin!

Hi, I experiencing this issues and has followed those steps but still there is nothing in my inventory nor my mail. I’m a newbie to this game and this made me pretty bumped…

I can’t even abandoned the quest :smiling_face_with_tear:




It just happened to me. I just went to char select screen and went back in the game. It was waiting for me in the mailbox.

mine still not appearing at all :smiling_face_with_tear:

Hello @hna.beilschmidt, welcome to the forums.

I’m sorry to read that you’re unable to progress your Awakening skill quest, as mentioned in the quest description, the item you need should be a relic item named “[Awakening] Enviska’s Might” that looks like a light blue sphere, this item is received directly to your inventory, as you mentioned that you’ve not able to locate it there please make sure to check your personal storage and your pet’s inventory.

If you still can’t find this item, please provide us with the name and server of your character so we can investigate further.

I’ll be monitoring this thread for your reply, have a good day in Arkesia.