Region Unavailable - Region is closed

I can’t choose NA West in the server selection page

But the servers look fine


Hello @Shinnika ! I hope you are well.
Thank you for reaching out with your concerns.

Is the first time that you are connecting or do you already have characters on this region?

I have the same problem since yesterday it just tells me that my region is not available,
it only lets me connect to south america and i’m from euc

1 Like

Hello @poizenxx ! Greetings and hoping you are well today.
Thank you for reaching out with your concerns.

Does it give you that message even when the server check is on green ?

This is not the first time connecting and I have characters in that region

1 Like

And the green check was on your server?

Same thing happened to me. my characters are on EUW servers. today I launched the game, but it automatically switched to SA servers, and I can’t choose any other regions and it says “region is closed”

1 Like

Same thing happened to me. I’m on enviska NA West.

No matter what I do, the regions are closed. I tried reinstalling the game, checking firewall, verifying files etc.

It worked briefly when I reset my router/modem but shortly after I got disconnected and can’t log back into na west enviska again.

I’m guessing this has to do with the bot bans and maybe some people got caught wrongly in IP ban?

This is really frustrating as I have spent money on the game and also am a trusted account. I have over 1000 hours playtime too and have never had an issue like this.

Please help us

yeah reinstalling the game worked for a short time. but immediately I got disconnected. after relaunching the game, it says region is closed, and I’m locked out to play in SA region only.

probably it’s related to IP bans because it works with Geforce Now


Hello Adventurers.

I am really sorry for this inconvenient. As we can see we are several with this issue. I proceeded to notify about this. As soon as I get updates about it, I will let you know.

We really appreciate your patience on this.

Safe travels in Arkesia. :crossed_swords: :man_mage:


I have the same problem which I am doing the chaos dungeon and disconnected(kicked by the game). I am from EUC but now can only enter the SA server. Followed lot of guides from this forum, it does not work :smiling_face_with_tear:

1 Like

Will they fix this in the coming patch? A lot of us really want to play Vykas this week. Argh

1 Like

This is some bullshit error that they can’t fix for months now.
It’s either somethng on their side or it’s because of Shit Anti Cheat.

If you disconect, get an error, your internet goes down there is a chance you will be blocked from that region. Only thing that worked for me to fix it was either wait, 10 mins to 2 hours for this stupid shit to fix itself or you can chance your ip or use exitlag to connect again

1 Like

It’s the same here. Already cannot login around 21 hours.

1 Like

Any update from the mods ? Same issue here…

1 Like

I also have the same issue. On EUC but its keeping me on SA and has the same message as the OP if I want to access any other regions.

Tried everything including Flush DNS, Firewall rules checking, reinstall of EAC, validate steam files, full reinstall of the game, port forwarding, turning off my router for the day.

Randomly dced last night whilst in stronghold.

Surprisingly it works with my mobile tether hotspot so maybe wrong IP ban?

1 Like

Same with me on EUC. A real shame, I love the game, but evidently AGS is indiscriminately banning IPs in a misguided effort to ban botters, who will always find away around the restriction, while gating legitimate players who have spent time and money on the game. It was a good run guys. Good luck to all who have not been affected.

1 Like

Guys I can confirm that it works if you use mobile hotspot. I also tried another internet connection (different from the one that I used before which causes the region closed issue) and it works.

So basically they have somehow banned or blacklisted your IP address for no real reason. I first had this issue when AFK and got disconnected for being idle too long.

Then after I wasn’t able to log back in due to region closed issue.

If you change your IP/ internet connection method it should work.

But obviously I do hope they fix this quickly as many of us don’t have the luxury of being banned from our home IP address.

1 Like

Same. Managed to connect with my 4G…

1 Like