Second Powerpass BUG!

Hello @andresfilipe01!

Welcome to the Lost Ark forum!

If you already did the steps provided above and your PowerPass is still missing please contact us via our live support channel so we can investigate your problem:

See you in Arkesia! :grin: :crossed_swords:

@Valret i followed that link got some dude from india who didnt know amazon owns lost ark. he put me on hold for 30 minutes then hung up. great experience. can someone from amazon please just send me another power pass so i can use my second one. thanks.

I sent a message to support and so far I have not received any response, there is nothing I can do to get a quicker answer?

Sorry for taking up your time but i really wanted to fix this asap, thanks again for your attention

Hi there.

@Marinagasolina I apologize i will escalate the incident, i would suggest you to contact us again since we need to take a closer look into your account.

@andresfilipe01 If you already submitted a ticket i suggest you to wait a bit more. Out team is handling the cases as fast as they can, also you can contact us via our live support channel to confirm if there is an update on your case: Contact Us | Amazon Games

Thank you for your understanding.

I, too have an issue redeeming my second powerpass.
I have already verified my files, and I have tried the character creation on a seperate server method. Both of thse methods have not worked.

Region: NA West
Server: Mari
IGN: Lolimaiko / Roumii

After activate my 2nd powerpass, I cannot use it.

Region: NA east
Server: Adrinne
IGN: Sasinblue (this is one I want to use powerpass)
Thank you

I don’t get my first powerpass after I did the quest

I am having the same issue.
Ign: Shadowalkr
Server: Aldebaran

Hello @wanderen00 ,

Greetings and welcome to the forums! :bouquet:

I am sorry about the powerpass. I see that you had raised a ticket for this issue and the team has now attempted to restore the mail containing your powerpass.

Please claim it on your mailbox as soon as possible.

Let me know how it goes! :sunflower:

Hello @lolimaiko @R3cnelis and @iamgil1 ,

Greetings and welcome to forums! :bouquet:

Please let me know if this is still an issue.

Please refer to above troubleshooting and if the issue persists contact live support using following link, to create a ticket specific to your account.

Looking forward for your responses on this :slight_smile:

Thanks! :sunflower:

Everything is good now
Thanks for your support

1 Like

All worked out well. Just claimed it and I’m using it now.
Thanks so much.

1 Like

I have the same issue. I claimed my second powerpass but it will not let me use it.
NA East
Ragefullchaos-This is the character I would like use it on.

Hello @mildleekaotic ,

Greetings! :handshake:

I hope you are doing good.

  • Please let me know if you have tried the workaround suggest in my comment above.

  • What is the error that you are getting after clicking on powerpass from character select screen?

Looking forward for your response! :slight_smile:

Thank you! :sunflower:

It says “Powerpass Available” under my character.

I click on Powerpass and it says “You do not have a Pass and therefore cannot use one”.

I have verified my game files and created a new character on a different server, but still no luck.

Any help would be greatly appreciated. Thank you.

Hello @mildleekaotic ,

Thanks for the information.

I am sorry the workaround did not solve your issue.

I request you to kindly contact live support using the link below, and create a ticket specific to your account for further escalation.

Thank you for your understanding! :sunflower:

I have the same issues as everyone, workarounds made no change. I also purchased the gold founder’s pack and believe I should have an extra one in addition to the 2 in game Powerpasses. I’ve used one so far but cannot seem to use another despite having the yellow Powerpass button

Server: Regulus
Region: US East
IGN: (received powerpasses from) Koineko, (use on) Koilancer

Claimed punika powerpass a while back and it shows that I am able to use it. However when I click on use powerpass, images do not render and I am unable to use it.

Hello @Born2rave ,

Greetings to you! :handshake:

I am sorry for the inconvenience caused.

I would like to inform you that the powerpasses are currently disabled temporarily. Here is the link to the official post:

Please follow the above link for an update.

Thank you for your understanding. :slight_smile:

Cheers! :magic_wand:

All powerpass have been disabled for the past 12 days. We still have no official communication on why (even though most think it is due to exploitation by bots) or an ETA on resolution.