[SHOP] Can't buy royal crystals

Today, when I click buy it just does a loading animation and then stops. I have bought them before fine. I tried restarting and nothing seems to work on my end.

Someone said it worked when you ran the game or steam in administrator mode, but also there are so many people trying to buy gems atm there could be some overloading on their side aswell. I’d say wait a bit.

Even when running steam in administrator mode doesn’t change anything :confused:

I found the answer. You have to make sure steam overlay is turned on. Right click game in library, then click properties and enable steam overlay. Then restart your game. Thanks for replying guys.


I did this too but steam overlay don’t show up

EDIT: oh, i didn’t activate it in the game, only in steam settings, might solve it, thanks !

Still can’t buy crystals, for 7h now

1 Like

Have not been able to buy crystals.
Steam Overlay is enabled through steam settings as well as through Lost Ark game properties.
I have restarted the game 10x with still no luck. When I press Buy+ and select a pack it will load for a few seconds then return to the original screen.

Still no luck in getting the royal crystal shop to work.
I closed every application that has an overlay thinking it could potentially help, and ran steam as an administrator. Only difference now is it started saying Purchase Failed.

Hey mate, did you try to:

Step 1:

Opt to force stop Steam: This is a favorable and necessary fix:

  • Go to Task Manager.
  • Proceed to force detection of Steam.
  • Next, we start the client.
  • Next we enter Lost Ark.

Step 2 -
On Steam click on on “Steam”
Click on “Settings”
Tick “Enable the Steam Overlay while in-game”
Tick “Use Desktop Game Theatre when launching desktop games while SteamVR is active”

Step 3 -
Open Lost Ark
Select a character
Open Mari Shop
Click to buy the crystals

Result: You will be redirected to Steam and you will be able to buy the crystals =)