[SOLVED] Didn’t get login reward legendary mount

I got the last day of login reward, but the mount, which was a reward in the side panel of the login rewards view, didn’t get to my mailbox! It says claimed, but I never got it, and it s not in my “mounts” menu, what should I do?

If you claim that reward you will have that in your inventory like any other mount. You need to learn it.

so let’s start prefacing that it’s not about me, not seeing / not knowing what to do.

I’ve played 400h, I’m 1350, and I claimed many mounts.
(not wanna sound like a douchebag, just giving the important infos so you know that I know what I’m doing :smiling_face: )

Last day of reward, I only got the “Pheon” reward (middle of the screen), but the special reward, the Chamkuri mount, was never delivered to me, neither via mail, nor in the inventory.
I didn’t learn it, because it is not in my “Mounts” selection.

I cannot find it anywhere, so something must have gone wrong.
They can check my account and see I didn’t delete it or whatever, I just never got it.

ok, servers just came back from maintenance and as soon as I did login I got the mount!!! so I guess this is solved!