Soul Harvest for Unas Bugged

Just did the Kungelanium raid and neither soul harvest increased my count for the unas Guardian Raid quest. Was this broken last night? I did the raid last night and both harvests counted but today neither did.

Guardian Soul if u enter with rest bonus 1 raid = 2 soul harvest

Guardian Soul only can be harvest 2 entry a day.

Yea definitely did not hit this cap.

I ran 1 guardian raid yesterday around 10pm, harvested both souls and got 2 souls harvests towards unas. Today I ran the 1 raid and neither soul harvest counted towards unas.

The only thing I can think might have broken it, is I accepted the unas at the end of the raid yesterday after the soul harvests had dropped, but again both of those counted while the 1 raid I ran today, neither harvest counted.

if you accept the quest after the kill it does not count anymore only befor the kill it counts aswell the soul for the unas if you forget to loot it ^^

But what’s weird is they did count. I went into the 1 today with 2 harvests already from yesterday. So does it break for all future guardian raids if you do that?

it not work like that… once u kill Guardian souls drop it already count as soul harvest u loot or not that soul it already count…

do u remember that screen pop up when u queue? Guardian Soul Harvest once u tick it… it counts.

meaning if u accept quest after souls drop it wont count/valid like that.

You’re thinking of the wrong soul harvest. That’s for entry count. I’m purely talking about una’s task soul harvests.

I accepted the Una’s quest after the kill yesterday. Harvested both souls. Got 2 soul harvests counted towards the quest. Killed the raid again today, neither soul harvest counted towards the Una’s quest.

nope i purely understand what u mean… i even explain how it count to una task soul harvest…
i just replicate your situations… except una task after guardian kill and soul drop. it didnt count on mine even i loot the soul… and then i enter 2nd raid it count mine 2/6.

i think u missed look?

if it really broken on your side perhaps best solutions is try abandon that quest and accept it again? so it reset.