South Vern Story Can't Destroy Towers While Underground Bug

I was trying to do South Vern Story for my new express character. For the quest ‘At A Journey’s End’ where I have to destroy the magick watchtower at the entrance to the valley, it doesn’t allow me to interact with the tower to destroy it. When hovered over, there is no indicator or outline saying I can interact with it (this applies to all towers in the area).

Searching this issue up, one person said it was fixed with a restart, but after restarting and verifying game files twice the issue never went away. I have another friend experiencing the same issue. And we cant complete the story line because of this.


(Mouse is hovered over the tower–as you can see there is no interaction when hovering over the tower, G key or clicking does nothing)

1 Like

i have the same Probleme. EUC -Server Ezrebet

it works if you just spam G. there is just no indicator. but spam it works

6 Likes

Thanks for letting us know there’s a workaround for this bug, toschi. And thank you for reporting this, KingOfBeast01. Please let us know if the workaround works for you!

The workaround did indeed work

1 Like

Thank you so much this worked for me!

1 Like

How

Thank you so much. This works for me too. Finally I can do Vern Chaos Dungeons

you are a lifesaver man

same issue, worked for me . Thanks!

I had the same issue, it also worked to try pressing G near the towers, I was stuck for a long time though… ):