Spot what's wrong with this setup


topnotch2

Had pleasure meeting this person in Argos

1 Like

Right on thier way to 5x3.

Did you talk to them or try to help ? Was it thier main ?

Or did you lololololool your bad ima post on forums.

12 Likes

why did you join this party or accept this person into your party

Had him in Argos MM.
Gave me good chuckle.

Looks almost as if its on purpose sooo Bad and still so many effects and to much hp for purple stuff …
But if u think about it a bit if its jsut a wrong stone from a whatever chaos set
with mass and blunt , and he has a cursed , grudge stone 6 / 6 he could make it almost properly … well at lest the engravings !

And here i am trying to build my alts with 4x3 at 1370 lol

1 Like

This guy is on challengemode , no doubt! :rofl:

well at 5x3 this would actually be great setup.
ANd he had stone 5/5/6

Check their roster level, might be their first character

Not that they will give a shit if you try to give advice ofc, but always worth trying a nice gesture

I have tried giving advice in the past but it mostly fall on deaf ears.

Exposing people. Nice

This is called the intentionally as bad as possible for fun setup.

mate, you are giggling at this one, but yesterday I had the pleasure to meet the first melee bard.

He had very bad engravings (stuff like propulsion, idk) and most of the time he was auto attacking.
He was not a bot, 100% sure.
the fun part of this is that he was 1340. I mean… how are you even able to reach t3?

I tried to reach out and see if I could help, but he/she ragequitted instantly when the guardian failed

Sounds about right.

Most people take it as insult if you try to help them out with advice.

ooooo i know this one, he’s still playing Lost Ark!

thank god not everyone is that much hostile.

I met a guy a month ago who did not know he had to move from rohendel to yorn to actually get past ilvl 600.

he was honing t1 stuff to +20 lol. Had to explain the system a bit and he was just embarassed lol.

+20…in t1 that’s impressive. Coulda been argos rdy lol

It looks like they may have forgotten to change their stone, or possible a preset issue.

I had a somewhat similar thing happen to me. My active set is preset 2 currently but when I entered an instance it swapped my books to the old ones (I’m sure I did it, I just don’t know how). It wasn’t a huge thing, and because I had class engraving in both presets it wasn’t this bad, but it is suspicious that it almost could apply here.

This. Has to be a joke. They took every “positive malus” there is.

Not 4x3.
Engravings > Stats > Playabilty