Steam still "stopping" lost ark after 10minutes

How did you fix it?

i didnt fix it dude i literally cannot play because no matter what i do it is still stuck at stopping. all i am saying is that there are many other players like you experiencing the same thing and we have to try our best to make our voices heard

Have you guys tried stopping the easyanticheat service?

doesnt work.

I got mine to stop fully by just waiting after i pressed stop running. idk how long it took but it did EVENTUALLY stop lol

Does your game freeze and need to be closed to steam? or worse than in my case I need to restart my pc because my game is frozen and doesn’t want to close even through the task manager?

truthfully i havent launched it since this happened so i havent played today and dont plan to play until they fix this awful issue. It affects steam and my computer not worth it.

But in regards to freezes i havent had them just the constant d/c AND the constant wont close properly.

1 Like

I have the same issue, what a joke game lol they really want us to quit

Its not game… its EAC crashing on u, and system has no acces to the game cuz of KERNEL, so it cant be closed.
BUT what do you expect from “free” anti cheat?

1 Like

I got the same issue… I had to reboot for fix it !! the good thing… the time it takes for start their game… I can reboot windows 10 like 10 times xD

1 Like

Well at the beggining I was confused but now I see I’m not the only one haha…I updated my lap, etc and even the game but it’s weird because I even turn off and when I turned on again…the game was still in “in played” hahaha so fucking awesome xD for real.

this also happened to me. I just went out to touch grass and somehow it stopped after the 5hs I was out.

This literally happened to me twice in a row. Tried to force delete lost ark so I can restart it and it just didn’t work. Had to eventually restart the computer. Funny thing is the only reason I exited Lostark was because both times I got stuck at 80% loading bar going into guardian (woohoo a different bug). So basically I just got fucking combo bugged. Fuck this game

When this happens you’re suppose to go to

task manager > process > background process > manually “end task” on lost ark so it closes it completely.

1 Like

Tried that and it wouldn’t work, only thing that worked was just letting it close for 10 minutes.

lies and slander

are you SUREEEEE it’s background process and not apps?

like close lost ark and EAC service

1 Like

When i tried to close it through background processes it gave me a error stating “i dont have permission” so no lies and slander. lol

For context, this was an issue that appeared in an EasyAntiCheat update last week, affecting a wide variety of games that use it (not just Lost Ark). The EAC service would lock the game program, keep it running as a background process after the game was closed, prevent the user from stopping it, and sometimes even re-run the game process automatically during the next Windows boot to eat up CPU capacity. Basically, it made the game act like a trojan horse virus.

The issue was hotfixed in an update to the EAC software 4 days ago—after this thread was created, but before you responded.

They fixed it, after you repair the EAC, it rolls back to the old driver on October 21.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.