Steam unpacked 70.2 of 70.8 then just stopped

Waited an hour to unpqck then after 70.2 or 70.8 it just stopped and now it wont do anything at all.

It is 99% unpacked and qont move, it’s been nearly 45 minutes.

1 Like

Any fixes yet?

1 Like

Please contact Steam support if you are unable to complete the decryption process

1 Like

Re downloaded and it hung up in the exact same spot.

Very helpful thank you so much!

About as helpful as a kick in the face

1 Like

It’s also not decrypting it wont even unpack.

It would be nice if you could provide a link instead of just telling me to contact them when they dont even seem to have any CSR other than troubleshooting.

Hi there everyone, I hope you are having an great day.

@Kamehamebrah just to check, have you tried to verify games files? Steam Support :: Verify Integrity of Game Files.

As for your concern, I do believe it is the best option right now, you can contact Steam from their website: Steam Support :: Update & Installation Issues

If you have any other question or concern feel free to ask. :slight_smile:

I hope this information helps!


Yes I have done all of these things. I am also not the only one having this issue either, there are still plenty of people in another thread that are stuck in the exact same spot as I am.

Got it, thank you for taking the time to reply back to us, we really appreciate it.

I still believe it is a good idea to reach Steam support to troubleshoot your client and if the issue persist then it is best to report it on the “Bug” section of the forum so our devs can get visibility of the situation. Bugs and Localization Feedback - Lost Ark Forums

I hope this info helps and thank you for the understanding @Kamehamebrah.

I’m sorry but you want me to post this same thing in the Bugs section when there is already a thread with over 550 comments in another section? I’m genuinely asking you this because I’m not understanding this. Not too mention how long it will take each of us to actually reach Steam for them to just tell us to restart. There is a comment from another community person in the linked thread that said Steam said it is an issue on their side that they mostly fixed but I believe this is a totally different issue all together.

Here is the thread that I am talking about:

What worked for me was going in my computers steam folder and deleted the beta folder manually. Hope this helps.

Progam files > steam > steamapps > common

1 Like

I had to make a totally different folder and have Steam install it to a different HDD.

1 Like

Hi there everyone, I hope you are having a great day.

@Kamehamebrah , I really glad to hear you were able to access the game and thank you for your understanding. :smiley:

To answer your question, we as customer service will refer you to the bug report section for visibility for the appropriate team, of course we will (internally) share any possible issues we can find with the developers.

I am really happy we have several Community Managers helping us during a lunch but they follow up a similar line of communication.

However, our developers will normally monitor the “Bug Section” a bit more than the rest of the forum sections. It means they’ll have a faster/clear visualization of the issue if we decide to post on the appropriate section of the forum.

Also, I wanted to thank @Quack for taking the time to reply to the post, we do really appreciate it. :slight_smile:

Btw, welcome to the forums! :partying_face:

I wish you have an amazing week, see you in Arkesia!

1 Like