Stronghold bug ever gettin fixed?

When is this stronghold bug gettin fixed?


seems like these guys went 2 steps forward 1 step backwards lol. when i frst got my stronghold I was like wtf.

Well I’m level 20 stronghold I’ve got labs unlocked but since last maintenance I’ve only got one lab able to research and it just says research complete always as 2nd labs vanished lol but I don’t see or hear anyone addressing it

Likely during the week. The patch that broke it dropped on a friday. Not the best day to drop new patches, since publishers and programmers also want a weekend. :upside_down_face: So counting workdays it dropped just a day ago.

It was acknowledged here: Stronghold research shows one slot, cannot start second research - #21 by Roxx

Workaround until it gets fixed: If you select to show All Available Research and scroll down the list you can find the completed research marked with an exclamation mark and complete it from there.

1 Like

Most game bugs and fixes require a client patch, and therefore downtime, in order to fix. Because of this, unless game breaking, most fixes will roll in during our weekly updates, as we don’t want to constantly take the game offline for every issue.


I’ve been stuck on “Issue For Approval”, the stronghold intro quest since launch and still no fix. It’s been 28 days with no stronghold.

1 Like

Why would a visual client patch require a server reboot or any kind of downtime? Doesn’t make a lot of sense since it should be fine server side


It’s not “game breaking”, but it’s high in the inconvenience scale. The stronghold is a vital system in the game progression and takes a lot of time to do upgrades, where upgrades help with progression greatly. Being unable to use a feature you upgraded for, in this example Lab lvls for extra slots is heavily deterring gameplay.

Now, if the team is unwilling to shut down servers for an issue like this, a great work around would be to provide players with free research acceleration chips as can’t use the 2nd free upgrade slot if the research was completed because there’s no way of getting the prompt to complete it.

I’ve tried everything. Verifying file integrity on Steam, I’ve tried putting a fast research first then a long research 2nd and a long research first and a fast research 2nd, it always shows the longest one on the tab. I’ve spent blue crystals by mistake because of this bug too.

So again, not game breaking but it is causing severe set backs at no fault of the player. But to toss out this kind of response for this kind of issue kinda shows you guys don’t really care about how this bug is affecting your player base.