Stronghold is broken after 6 hour maintenance

So, after the long maintenance it would seem like you managed to break another feature in the game? I am missing a second dispatch and research slot in my stronghold, it also says that previous research/dispatch is complete, but I cannot claim them after clicking on the tabs, because it suddenly changes it’s mind that it’s still in progress. I tried exiting out of the stronghold and going back, not brave enough to relaunch the game because of the fat queue I’m gonna get slapped with if I did so. Images are provided to display the issue.



Same goes for dispatch missions, not gonna spam the thread with more images.

1 Like

yeah we know… just klick on top in the forum plz next time before opening up ANOTHER one of this

At the time of writing the post I didn’t find this thread? Not to mention sometimes it takes multiple threads for them to finally acknowledge and issue on EU so…

1 Like

no it takes 1 big thread like all the other problems … thats how it worked the last days and when did you write this post? multipe threads are open since the servers are up again …
there open threads for 7 hours now

Bumping this since I still haven’t seen any acknowledgement from the CM’s.