Stronghold Research Slots Missing

Adding myself to the list of those affected.

I am also affected by this issue.

Having the same issue, additional slots for research missing. Was able to complete one mission that was finished by going to the “All Research” tab, but side bar still missing.

Same here

Same here

Same. I also answered on this other thread → Missing research slot

1 Like

Hello Everybody:)

1st time poster, so please bear with me.

I had same issue - there is a workaround that worked for me. I hope it works for you all - while you’re in lab tab, filter by “all research” and scroll down to find blue exclamation mark (finished research). Click on it and I was able to finish it and start new research after that.

Hope it helps:)


Same, and people in area chat complain also. #Maintenance #Painofgamedevelopement

same problem here, cannot seem to collect the finished research in the 2nd slot. and only sohwing 1 slot. since 3/4 patch

Yo, good workaround. Kudos to you.

Chill, bro. You can always brake something unintended when you are fixing code. It is not game breaking.

1 Like

Nice one, worked for me :slight_smile:

Didn’t even think about completing the 2nd/3rd research from the All Research list. You’re awesome!

Got the same bug but now i cannot complete one of my researches as i cannot see them at all

Also having this issue.

OK. it seems to be a GUI / Usability Bug.
You have to complete it via the workaround posted here (View all researches)
Or you have to complete both researches before starting a new one. By double clicking on the “complete research”

if u check out “all research” u can finish the completed research which u cannot see

Hi All,

Same here:
Outside stronghold I can see that i got 2 researches:

Inside Stronghold I can see only 1

Same here, I only can do one research at time now…