Stuck in Character Selection Screen

i sent a message to the support team and no response yet before i made this forum post

The specs for my computer is good for the game i checked the link u sent me

Hi @Folareon,

Thank you for getting back to me so fast, if you have sent a ticket already that’s great! It might take some time for our team to get to your ticket, so please give them 48 hours before submitting a new ticket.

I will keep an eye out in case I find a possible solution!


Have the same problem since installing the patch today. Verifying file integrity did not change anything. Looks to be an EAC issue with specific ip addresses?

are you guys using exitlag? i had the same problem and turned it off and i got into the game but since i cant play without exitlag it doesnt matter games fucking shit.

yeah im using exit lag

try starting game without exitlag and let me know if it works

yeah ill try rn

Hi @alexfosterhill,

I’m sorry to hear that you are having the same issue, if you are having an EAC problem please check our most recent thread here:

If the issue persist try contacting our support in the link above!


i turned it off and it worked but i need exitlag lmfao

thats what im saying, fucking dogshit game blacklisted it or something, cant play without exitlag, cant play with exitlag

guess we go to amazon shit support wait 48h and get no productive help

@Jormungandrh it has to do with exitlag routing. at least we know the issue now.

1 Like

Hi @alexfosterhill,

Feel free to include this post in your ticket, so the team handling your case has visibility of this!

They will be able to investigate further!


still havent recieved a reply

Same Problem here, but at least I know now that problem is related to ExitLag.

Same here, can’t really play without it, having huge disconnect issues in raids (that started months before a lot more people got DC problems). Nothing else could solve the problem, I really tried everything. Till I found ExitLag :disappointed_relieved:

Btw if you start ExitLag after you log in with you character, you immediatly geht the famous SPELP-Disconnect Message


Hello everyone!

Thank you for sharing more reports and findings, I haven’t been able to find a solution yet so right now our support team are the best way to get this investigated, as I mentioned before it might take some time for our team to be able to get to the tickets but I will keep my eye out for any way I can help!

Thank you for your patience!


this is my mail from amazon support, apparently im playing new world after exchanging 4 mail replies. good shit

Hey Samshara.

Can you check in ExitLag if you select Frankfurt 01 as server? This one seems broken. I switched to Frankfurt 02 and can use the programm normally again. Another guy said he also “fixed” it by switching from Frankfurt 01 to 03 in his case.

If you are not using Frankfurt server at all, you should also try to select a diffrent ExitLag server of your region. Maybe another one is working.

Hopefully it helps