Stuck on loading screen at 90%

Hello, I have some issues with loading screen, sometimes it’s stuck at 90%, sometimes it’s loading smooth, for example 10 minutes ago it didn’t load and now it loading.
I tried to check verify integrity of files, every update windows, gpu, etc.
What I done wrong, or what is the problem?

Hey @cristibarbu22 I hope you’re doing great and I’m very glad to welcome you to the forums!

Really sorry for this situation you experienced being unable to completely launch the game, I understand you have already tried verifying the steam files integrity and restarting the game+computer as well made sure everything was up to date, awesome.

You can try the following:

Repair Easy Anti cheat ( Open Lost Ark Application in your Steam library and go to Settings → Manage → Browse Local Files > Open the AntiCheat Folder > Run the EasyAntiCheat_Setup executable file > Repair.

  1. Troubleshoot the Firewall:
  2. Press Windows + R, type “firewall.cpl” into the Run window, and then press Enter.
  3. Click Allow an app or feature through Windows Firewall and then click Change settings.
  4. Look for the game in the list of allowed apps and features. If it’s present, make sure it’s checked, and that both the Private and Public columns have a check mark. If the app is missing from the list, you need to add it. Click Allow another app…, locate and select the app, then click Add.

If the issue persist please let me know so I can check this further, as well If you’d be so kind as to give me your character name and server/region I’d be helpful!

Wish you a nice day and see you on Arkesia!

Now it’s working just fine, thank you, if I will have the same issue I will let you know, server it’s Evergrace Central Europe and the character’s name is Coiomoio.
Thank you again!

Hey awesome to hear you’re no longer experiencing this situation @cristibarbu22 and sure do, remember you can reach back if the issue persists!

I tried this, didn’t help. Game stuck in loading screen all the time on all 7 characters. CPU is at 50-60% and the game crashes after a couple of minutes. Firewall seems okay. game worked flawless before the latest update.

Hey @CptZaepp I understand you’re experiencing this same situation as OP and I’m deeply sorry you haven’t been able to launch the game properly.

Did you try to verify the steam files integrity? I’ll proceed to look for further steps and reach you back as soon as I can, see you around!

Hey @Legumi yes, seems to be a similar issue. I tried pretty much everything I can think of:

  • verified files multiple times
  • tried to load all of my 7 characters
  • reinstalled the game
  • removed the configs and started the game
  • a colleague of yours moved one of my characters from Kalaja to Prideholm
  • checked if all the drivers & windows is up-to-date
  • checked the firewall in case something got blocked

The client worked flawlessly before the recent update.

I opened a ticket with amazon support.

Hey @CptZaepp appreciate your time to post the steps you’ve attempted, I’ll proceed to search for further troubleshooting we can do to try to fix this issue.

It’s great that you were able to submit a ticket and hopefully soon they will able to provide a definite solution, on the meantime I’ll try and check what else can we proceed with!

Hope to reach you back soon!