Sudden region unavailable after relog

Hey guys, I am wondering if anyone else has the same problem as me. I been playing the game in NA East with no problem since launch (have over 1000 hours atm) and earlier today I relogged and an error message showed up saying: Region Unavailable The region is closed and can’t be selected.

The problem is I can select other regions and servers and play on new characters with no problem but I just can’t seem to go back to NA East where all my characters and friends are playing at.

I contacted live support and they just redirected me to dev teams and asked me to wait, so just want to see if anyone else has the same issue and maybe has a solution.

I looked everywhere online and seems like that a lot of people have the same or similar issue, most of them were unanswered, and the one that claimed to have the solution, I tried and nothing worked.

EDIT: 1. never played with vpn
2. not firewall issue (other region works)
3. refreshed and renewed dns
4. uninstalled and reinstalled both steam and Lost Ark several times already
5. tried verifying the integrity of the game

2 Likes

I just had the same problem and I thought it was really weird. I restarted my computer after a couple of relaunch attempts but everything works fine now.

I also verified the game before a system restart

1 Like

welcome to the sacrificed for the sake of bot combatting club.

  • if for every 1 bot AGS blocks 2000 real players, they did their job

i’m glad yours is fine now, i still have no luck :<

Same issue as well. :frowning:

Did you manage to find a fix or workaround? This issue is popping up for me and its so frustrating.

Hello and welcome to the forums @Bisu and @WinterStratos,

Our apologies for the long time this thread took to get an answer and thank you @Symoh for bumping it with your last reply. I am sorry to hear you seem to be having issues logging in to your usual servers.

Please try the following steps in order to troubleshoot this after checking if your server is up and running here:

1- Please verify the integrity of game with the Steam integrity check
How To run a Steam Integrity Check
2- Close other applications that may be taking up your bandwidth.
3- Switch to a wired connection.
4- Restart your router and modem.
5- Troubleshoot your firewall.
-Press Windows + R, type “firewall.cpl” into the Run window, and then press Enter.
-Click Allow an app or feature through Windows Firewall and then click Change settings.
-Look for the game in the list of allowed apps and features. If it’s present, make sure it’s checked, and that both the Private and Public columns have a check mark. If the app is missing from the list, you need to add it.
*Click Allow another app…, locate and select the app, then click Add.
*Once you’ve done that, you need to ensure that the app is checked, and that it has check marks under both the Private and Public columns.
6- Test your connection for packet loss or buffering. To test, go here and click the big Start Test button to start the test. Once the test is complete, the results are displayed.
7- Verify you are not using VPN or proxy services. (Note the use of VPN is not permited when connecting to our servers).

If the issue persists after this, the scenario will require our tech team to look into your logs and follow up directly with other possibly sensitive account information that is best not posted on the forums so it would be best if you could please create a web ticket by going to Contact Us | Amazon Games.

I hope this helps and if not, do not hesitate reaching out to live support.

See you in Arkesia! :wolf: