The guide quest [Honest Liar] item lost bug

the guide quest [Honest Liar] in stern, need to have the item [], im sure the map was in my bag and i did nothing to it, but it disappeared and i had no way to obtain it again. I searched on internet and found there used to be same situation in Russia servant and turned out to be a bug. I need to complete my task, pls deal with it asap

1 Like

same here, the map was in my bag but the moment i start the robot, the item vanishes from my bag and now i’m stucked with this quest

The same exact bug here as well.

In another game I would have looked around because “maybe the bot just ate the map and I should look for another”. But I don’t think it’s voluntary from AG…

I had the same problem but I fixed it.
Test this :
Click on the NPC → click on the quest left in the corner → press 2x “G”-> then click with mous 3 or 4 times on the NPC in the speak sequece . Now the Answers should appear.

Hope this help.


This worked for me

Also worked for me but i spammed clicking on the quest in the bottom left and G.

It seems it’s intended by the questline actually. They got me on this one :slight_smile: