The region is closed and can't be selected issue

Hello I am playing from Europe on EUC Zinnervale. Have 870ish hours and this happened for me 1st time.

Yesterday I logged in and firstly saw pop up like I am logging in first time to accept rules of the game or smth and then I was locked in EUW region. Couldnt choose any other region other than EUW, after I relogged, problem still was there. After that I restarted my PC and router and verified game through steam and now I am locked in South America, doing same things again dont change region. I can choose any server in SA and even create character but cant connect to my server.

Then I saw that a few people on stream I watched got that error too and I thought it is maybe temporary or servers currently unstable and decided to wait for a bit. But after that I saw that my friends and other ppl from my region is playing normally and found only old february topics about this issue where it was just magically solved by itself. And saw again a few ppl with this issue.

I tried: restarting PC, reinstalling, verifiying game files, restarting router but nothing helped. Didnt try VPN cause it is against tos as far as I know.

Pls help

1

5 Likes

im like that too . today i got access only to SA yesterday i could access EUW as well, now EUW is gone too :))

3 Likes

At least I am not alone…I imagine what they did now with this game xD

2 Likes

Hey @AlexHero Welcome to the forums!

I am sorry to hear about the issue connecting to the server, it seems to be the same problem I was checking with @refah50 so in this case I would recommend to reach us directly so we can investigate the issue and escalate it, here is the contact information:

Let me know if you have more questions.

1 Like

Thank you, already submitted a ticked, but thought that someone here already knows the solution.

2 Likes

No worries! I am glad to hear you were able to submit that ticket, Right now as you mentioned I don’t have a solution for it but I am still investigating, if I find a fix or a troubleshoot for this issue I will update you here.

2 Likes

Hi Fostus! Was there a fix or possible workaround to this? Alot of people seem to be getting this issue.

But as highlighted, if you switch to a different internet connection (i.e. mobile hotspot 4g, or another wifi network) it seems to be work fine again.

2 Likes

having the same issue right now, is a bit annoying

2 Likes

Hello @zekkeh,

I am sorry to hear you are experiencing an issue similar to the one on this thread but I heavily suggest against replying on top of older posts in order to avoid having yours overlooked and also due to the fact several patches have been applied since this post was last replied to, possibly addressing the initial issue and even if yours seems similar, it may not be the same.

Please note that it the troubleshooting provided earlier in this thread did not clear it for you, the next suggestion @Fostus made was to create a support ticket for review, so do not hesitate doing just that.

Good luck! :wolf:

Hello @Fenrirskoll ,
That happened to me today.
is there any way to fix now ?

1 Like

Hello, same problem here

1 Like

same problem I can no longer select the “Europe” region

1 Like

can connect to EUW with my phone internet but not with my box dafuk ? not using any kind of VPN or external soft to connect

same here being dc from ealyn, i am in france with a free aperator and getting stuck in south america i dont know why, no vpn or else

actually doing a ticket will try my 4g box/modem

1 Like

free here too

use a share connection with your phone for the moment , it’s ok for me ! problem with free !!

I have this issue now icannot log into the game

@Roxx @Fenrirskoll help plz

i can have the choice to change region by using my 4g connection, clearly a pb from fix connection with operator

@Roxx Help pls. Support is not responsive.