I was doing this quest line but I think I am now soft locked from finishing the quest. After inputting the item into the robot at the “Honest Liar” quest after the cutscene my map has disappeared and I cannot proceed any further in the quest. I think this is a bug.


Same thing happened to me.

it happened to me too

Have the same problem, if someone know how to resolve pls help ! Ty in advance

^ Bump

Same issue, after cutscene treasure map is gone - checked inventory, pet inventory, storage, no mail etc.

Hello everyone, I have figured out the solution. The quest itself is bugged it seems but if you stay on the talking screen for about a minute then try to talk to continue the quest, the quest will properly continue.


Hi, where must I go to do that ?

Do you leave the talk screen then talk again or just click to talk after a min

This quest is still bugged. Waiting a minute didn’t work for me but spamming G for like 10 seconds did. Idk man


Yes, but… WHERE ? XD

I only have the pergamin and I do not remember who give it to me.

I found the solution, you have to stay 1 min without touching anything during the “…” dialog then after you have to click with your mouse on the “G” button at the bottom right it’s important not to do anything during 1 minute

Spamming G worked for me!

1 Like

thx spamming g works

G Spamming works thx =)

Spamming G works for me too, thank you very much

Thank you guys! Worked for me as well!

spaming G worked thanks :hammer:


spaming G work for me too :smiley:

1 Like

Here is your walk through:

1 Like