Took my Royal Crystals but no gold was claimed

I purchased gold through currency exchange for a quantity of 50(worth $100 of Royal Crystals) for a Sale Price of 699 gold.
It was accepted and the gold, amounting to, iirc, 34000+gold appeared in the claim section.
I clicked claim and it gave me a loading icon but the 34k+ gold has yet to appear in my inventory.
I restarted my pc, ran steam on admin mode and verify the integrity of the game files. Still, golds are still not appearing.

These are the screenshots that show that the transactions of the “Successful Sale”. The 34k+gold appeared and I claimed it and then it was gone. Never appeared in my inventory as you can see in the picture.
It does not even show that it was “Claim Gold”, like the other transactions below it, even though I clicked claimed.
I also purchased another one just to see if it will happen again but this time it was Claimed as you can see on the other picture.

IGN: Krooz - Ladon Server

Hi @krooz!

Thank you for posting your concern in our forums!

I am sorry to hear that there was an issue while buying gold. Please contact our customer service to file a ticket on your behalf and have a better look into your issue.

Hope you have a great day!

See you in Arkesia!

1 Like

Has your problem been solved? I have met the same situation.

Yes, I submitted a ticket along with the statement and pictures above and I also added a screenshot of my steam purchase that day. It took 5 days to get resolved.

Thank you. :smile: