Twilight Chapel wont load you into the instance

Doing the quest “Twilight’s Claws”, after putting on the disguise and walking to the portal that takes you inside the chapel, nothing happens, it bugs out and no dungeon window pops up for you to enter.

I tried to restart game, abandoned quest leave the area back to ship, and nothing works.


Having the same issue, no second awakening for us I guess :cry:

Also noticed that the chest rewards from the quests are blank. for example from a regular chest I see the rewards possible:

Where as with these chests it shows non of the rewards:
They all also seem to be the same “Normal Chest” name for their “possible rewards” panel instead of the usual matching what the item says.

1 Like

I’ve just encountered the same bug, while doing the Awakening quest.

1 Like

me and my friend encountered the same bug, we couldn’t access the portal that starts the dungeon.

same here cant progress with second awakening skill because of it

I’ve had this same issue. I’m thinking this is more relevant than it looks like, could be something messing with character data and so we can’t continue the quest nor open the chest? Here I posted some more info on this bug.

same issues with blank chests from reward
+cant go in instance from Quest

Does not work for me either

Had the same thing happen to me. I just left there thinking it was closed off because of beta. Reward chests were empty too. (Can’t open them) Also, it may be unrelated but I can’t progress with the purple quest in another island. I’m not sure but it was something like Shadow Island, I guess? There was a tower. Quest was asking me to move to floor 24 but couldn’t progress beyond floor 5.

Reading the descriptions of the chests it appears those chests were accidentally set to have Tier 2 mats. That would explain why they are bugged.

Would like to add that I’ve also encountered this bug as well as the three or so people that showed up while I was trying to figure out a workaround.

Same here, dungeon icon appears on a map but can’t enter, chest rewards don’t work either.

same here, chapel entrance is locked plus empty chest rewards

same have the same bug cant go in to the twilight chaple its buged

Same. I tried canceling the quest, leaving the island, restarting the game. Nothing helped. The chests are empty and cannot be opened.

in this Q you must go to “classic” tower in towns and doo something on 24floor … i think it was destroy big crystal :slight_smile:

Yea that quest you can do in the town if you go to the tower, the island only has 5 floors and then you do the 1-24 in a town. at the tower of chaos i think it was called. usually next to the cube.