Unable to Enter Grand Prix Event


I’ve seen some similar posts, but not exactly what I’m experiencing. If I missed something, I apologize.

When the Grand Prix Event first started I accepted the quest and was able to race on two of my characters. I did so for a couple of days until I started receiving the error you get when you try to enter without having the quest. I was receiving this error on the same character (my main) that had done the race multiple times.

I figured maybe I accidentally accepted the quest on an alt and forgot to actually do the race. I went through all of my characters looking for the quest in the quest log and did not find anything. I even went so far as to abandon all the quests I was able to. On top of that I attempted to enter the race with each of my characters only to receive the same error message.

My main and all of my alts are level 50 and would qualify for the race if the quest was accepted, however, NONE of them can enter the race. This has been going on for more than a week. I was enjoying the races, not to mention the currency received. Can someone please help?

Thank you!

Hello there!

Sorry to hear about this unpexpected change.
We will gladly file a report so devs can look into this.
Could you provide the characters name, world and region you are on?

On the meantime, some of this issues are flushed by closing the game, running steam as an administrator and verifying integrity of Lost Ark on Steam.

I would suggest going back to the NPC that gives the quest and checking if it offers quest again or speaks as if it was already handed.


Hi DevonK,

Characters that were previously able to race:
ClunkyPenguin - Kharmine - US East
Pheoguin - Kharmine - US East

I have already tried the troubleshooting you mentioned on a couple of occasions. I’ve also updated, tested, repaired everything surrounding the game, steam, windows and hardware in general.

Please let me know if there is any additional information needed or other troubleshooting I can try.

Thank you for all you do!

I see.

Thanks for the info, will file a report and keep you updated.
(Happy to help)


Thank you so much!

1 Like

Hello there, im having the exact same issue, this is my haracter

Parogo - Trixion - EU central
Paroga - Trixion - EU central
Paroguina - Trixion - EU central

Ok, will add you too, thanks for the patience,

Cheers !

Thanks !

Im now able to enter, I dont know if you did anything but wanted to let you know

Unfortunately, I’m still stuck and unable to enter. :frowning_face:

I’m having the same issue where ! accepted the quest on my alt which isn’t level 50 so im unable to do the quest or abandon it

Galatur-NA east-Nobodyas