Why can't i use my Punika's pass?

Hello, i have a little question…
i’ve used the Punika’s Pass, some days away , and now i cannot use on my new character, and i just want to know why this.
Can anybody help me?

In short, shits broke yo. Update will be given soon by CM’s. (Expect mid-weekish of next week)

Ohw… what a shame… But ty my man.

1 Like

It’s not broken, botters used stolen credit cards to buy punika passes and SG disabled powerpasses altogether for everyone, even free ones

Really man? Yeah, I didn’t list 8 reasons its more than likely disabled. But I’ve been helping people all day that ask this same question. Doesn’t change the fact that atm, shits broke. Thanks for your help.

Welcome to the community @rickcorreia! As stated, the powerpass has been disabled.

I’ve noticed you helping out other players with this question. We appreciate you @pyroaddict04 for going above and beyond.

I will mark this thread as solved. :slight_smile:

1 Like

I understand why you did. But that solution held a special place in my heart lol.

1 Like

Really ?? You hype it, thieves crack it, steal it and because it’s too much bother to fix it, you disable it and call it “SOLVED” ??