Will the Developers Ever Acknowledge and Actually Fix the Stuttering/Hitching Issues?

I have been patiently waiting for a fix to the stuttering issues I’m having in this game. The problem is, now that I’m grinding away at end game content, it’s to the point that I don’t even want to play. At all. I experience constant stuttering and frame drops.

My system is pretty solid and I don’t have issues in any other game including high-end and demanding titles that just eat up system resources. Running an RTX 3070, 3600xt, and 16 GB of RAM and a solid, high-speed fiber connection for Internet. Tried all the suggestions I can find online, including:

Power settings to high performance.
Updating drivers.
Running the game only.
Completely disconnected my second monitor to eliminate the theory of 2 different refresh rates causing the issue.
Disabled all area and loot chat and even all chat.
Tried every possible combination of border less, full screen, Vsync on or off, Gsync on or off. Every combination of capping refresh rates and FPS that made sense such as 144 for both and even 60 for both. Tried all of this with every possible combination of the Vsync and Gsync on/off as well. Cleared all of my shader caches and verified Steam files.

Low and behold the experience is still completely ruining my chance of having any fun in with this game. I enter dungeons and stutter around while everyone else is getting their damage in. PVP is really a matter of hoping I don’t stutter while engaging and I usually recover from the stutter to see I’m already stunned or in the air getting a combo smack-down put on me. If the developers will not acknowledge and show some real effort in addressing this issue which A LOT of others are having as well, I can’t keep playing this game. As much as I want to.

I finally decide to post this here today after seeing no mention of a fix for this in the latest patch notes. It’s surprising considering how many post I find online with others having the same issue with high end PC builds. It’s clearly the game or servers causing the issue.

are you running AMD? with a quick search theres issues with AMD with a bios fix… not ideal, but it works.

Im not, I’m running on an i7 8700 with a 1080ti with 32 gigs (4000), and have ZERO issues. Also looks like some “newer” 2xxx/3xxx nvidia cards are having issues with GSYNC.

I am running AMD and I am aware of the stuttering issue caused by certain TPM configurations in the BIOS. This is different however and there are a ton of Intel users having the same issue in Lost Ark. It definitely feels like a GSYNC issue but the fact that I only have the issue in THIS GAME, just like so many other players, is revealing. I have no issue until I play Lost Ark.

as I said, Im running 1080TI and dont have, nor have I had the issue… sounds like its card/driver related, but since you’re also running AMD, its gonna be hard to isolate.

Granted, neither of those things SHOULD cause a problem, but… thats where its at… for now… and hopefully gets fixed… I havent seen a user end solution for the 2xxx/3xxx card issues but havent dug since I dont have one.

I appreciate the input but I disagree to an extent. As I’ve said, there are a ton of others having this issue while running both Intel and AMD and they only have the issue in Lost Ark. If this were isolated to the card/driver, I really doubt it would be with one game like this.

Im not saying its not lost ark… im saying its an issue with LA and that hardware…

I know theres an amd “fix” but havent seen a workaround with the gpus. Im sure theres something until its fixed though. I agree its an issue that needs to be adressed as well… since its not effecting everyone though Id assume its low on the totem pole, and hopefully nvidias next set of drivers fix it from that direction… thats probably your best hope.

It’s Lost Ark.

I can run 144fps in cyberpunk with no stutter but Lost ark acts like a mobile game running on pc through an emulator.

1 Like