Won't let me dock at yorn

i have the quest, telling me to go to yorns cradle.

but when i go there it doesnt let me dock or anything

im ilvl 820, why isnt it working?

ok it works on my soulfist
but not my deathblade

my soulfist got 600 first, then i used the research upgrade stuff to get my deathblade to 600

how do i get my deathblade to dock there?

it was my plan to get my deathblade to be my main instead of my soulfist, so i’d much rather do it on the deathblade… what are my options?

did you finish the yorn guide quest?

i can’t even dock at yorn
the quest says go to yorn cradle, the docking station at yorn

i cant enter yorn

i still think it has something to do with a spot you have to touch on your way to yorn, getting that quest updated is likely the solution

can you elaborate please?

my soulfist didnt touch anything i dont think, on the way there

You will need to do the Rohendel Quest line before you are able to go to Yorn.

I think it has to do with the crashes a few days ago. I had the same issue and had to do this crazy workaround to be able to dock: [US West Mari] - Character stuck stranded at sea

Still can’t get into Outlaw Isle though sadly…

im not stranded, i can leave
it just does not register me properly and wont let me dock at yorn

i can dock other places, it doesnt think im lvl 600 i think

ive done rohendel
how else would i get to ilvl 600?

You need to do it on that alternate account. Quest lines are character specific. Also, you can get ilvl 600 even if you only stay in Vern.

i see, but ive done rohendel already on the db
my db has the quest telling me to go to yorns cradle

i honestly hope im missing something and that its not bugged but ive tried a lot of things, i really think it’s bugged

i contacted them and it should take a couple days and i should hear from them hopefully it gets fixed

ok so, i tried to go from vern to yorns cradle and it worked
for some reason, when i bifrosted to rohendel to get to yorns cradle faster, it didnt work
causing the problem to not let me dock

but when i went straight from vern to yorns cradle it worked
not sure if this is a bug or not, either way its solved now