Yet again... EAC 30004+++

EAC keeps getting the error code 30004 when I try to play. Usually, every couple of weeks or so, the game randomly stops loading due to EAC (I can tell while it’s loading because the bar flickers whilst it loads). The first time it was this same error code (30004), and then error code 30005, and then the same one that happens all too often now, which doesn’t have a code at all but just takes about 10 minutes after the EAC window closes for the Lost Ark art to show up, and then another 10 minutes for it to load. After that, the game freezes, stutters and just generally barely runs.

Now for the first time in a while, it’s gone back to the original error. I don’t remember what exactly I did to get rid of it initially but some fixes I’ve seen online relating to it haven’t worked at all. I am on Windows 11. I have reinstalled/repaired EAC various times, verified game files various (4!) times, updated Windows, checked for game driver updates which are not necessary and nothing has worked, so I’ve been playing on GeForce NOW. I waited a day after doing all of that because if I recall correctly that was how it was ‘fixed’ the last time too. Nothing. Last time I also reinstalled the game but that had no effect, so I didn’t want to go through that again. From the pop up: Unexpected error. Wait for single object failed: 2, I think there is an issue with a missing file or something. But this happened on Thursday.

I played on Wednesday perfectly fine and there was no patch anyways so literally nothing could’ve changed. I have never downloaded anything dodgy and the last time I downloaded ANY program before that was the Brave browser on the 14th of August. Between now and then I think there was one random error with EAC (the unnamed one I described) but it wasn’t related to that, it happened before that too. I don’t remember about any updates but I know there was no update on that day or Wednesday. I DID update after that happened though in case there was a chance it could fix it. Anyways, I need this to be fixed. PERMANENTLY if possible. But I doubt that would be, since this is of course, an EASY ANTI CHEAT issue. One of many EASY ANTI CHEAT ERRORS that happen in a lot of games.

I have gotten lucky with EAC Offline at least, I only got that once. And I rarely get disconnected during raids. But this is a big issue. I would like some help please. @Roxx
Or whoever can help lol idrc

I have issues since 1h too, game is just not starting after EAC but without any errormsg…

For that particularly, if it’s the one I usually get, maybe repairing files by using the browse game files option in steam and then going into binaries > win64 > easy anti cheat > easy anticheat setup, and THEN verifiying game files and restarting your computer will fix it, usually it does for me.

working again, it was windows cloud who was blocking… no idea why but it was…

I’ve moved this to the support section as our support team is better equipped to handle technical problems.

Hi @mastermasher and @Oriental

Hope you are doing well.

I’m so sorry for the problems you are getting with the EAC.

@Oriental I’m glad that you find the windows cloud was blocking and causing the problem and you solve by you end.

In order hand @mastermasher I would like to share some troubleshooting steps for this issue.

Here is the link:

Amazon Games

Troubleshooting EAC Issues - Support | Amazon Games

Support for Amazon Games. Read support articles or get game & account help from Amazon Games support reps.

Did you Try adding Windows firewall exceptions manually? if you didn’t do so:

Press Windows + R, type “firewall.cpl” into the Run window, and then press Enter.

Click Allow an app or feature through Windows Firewall and then click Change settings.

Look for the game in the list of allowed apps and features. If it’s present, make sure it’s checked, and that both the Private and Public columns have a check mark. If the game is missing from the list, you must add it.

Click Allow another app…, locate and select LostArkLauncher.exe, and then click Add.

Once you’ve done that, make sure that Lost Ark has check marks under both the Private and Public columns.

Also you can try what @Oriental did to verify if that steps help you.

With any updates please, refer to this post for further details about this situation:

Also in this case we like to take a closer look into this issue with you, when you have a chance, please use the link here to speak with our Customer Service team:

Contact Us | Amazon Games

Please make sure to have the DxDiag ready once you reach support, you can pull it following this steps:

DxDiag report:

Go to Windows Start search bar and type dxdiag.

Click on dxdiag.exe.

When green progress bar goes away, select Save All Information and save the file to their desktop.

Also please make sure you send this link to the agent so we can help you to investigate this issue and see if is related to the Mega Thread, also give them all the information needed. And please let me know how was it!

Hope this information help you! :wolf:

it says if you have a problem with eac go to their support. also, there is no lostarklauncher.exe, there is just LOSTARK Client and Lost Ark. I also did what you said for EAC Service.

Hi again @mastermasher

Hope you doing great

Thank you for your reply!

If you did all the troubleshooting steps I shared with you and none of them works for you and you still have the same issue with the EAC please reach out our support team by creating a e-mail if you haven’t done it to help you further and create a ticket to the Devs team.

The link to reach them are the same as I shared with you in the post above.

Hope this information help you and have nice day! :wolf: